using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:[^""]*""?[^""]*"")*[^""]*$)";
string substitution = @"\n";
string input = @"""This is a string"", ""and this is another with a , in it"", Thisisalsovalid, "",,,""And a string""";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}