use strict;
my $str = '"This is a string", "and this is another with a , in it", Thisisalsovalid, "",,,"And a string"';
my $regex = qr/,(?=(?:[^"]*""?[^"]*")*[^"]*$)/imp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";