import Foundation
let pattern = #",(?=(?:[^"]*""?[^"]*")*[^"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #""This is a string", "and this is another with a , in it", Thisisalsovalid, "",,,"And a string""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)