using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((\d+)(\.\d{3})*(,\d{2}))|(\d*))$";
string input = @"234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454.238.890,00";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}