re = /^(((\d+)(\.\d{3})*(,\d{2}))|(\d*))$/
str = '234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343452342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454323423423423235353453445345534345432342342342323535345344534553434543234234234232353534534453455343454.238.890,00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end