import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s+href=\"\\.\\/view\\/(\\d{7})\\/\">";
final String string = "<a href=\"./view/3049532/\">\n"
+ "<a href=\"./view/398562/\">\n"
+ "<a href=\"./view/3652872/\">\n"
+ "<a href=\"./view/3785471/\">\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}