re = /<a\s+href="\.\/view\/(\d{7})\/">/
str = '<a href="./view/3049532/">
<a href="./view/398562/">
<a href="./view/3652872/">
<a href="./view/3785471/">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end