const regex = /SMS_TRIGGER:\s([a-zA-Z0-9\-]+).*SOURCE:\s?([a-zA-Z]+).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SMS_TRIGGER:\\s([a-zA-Z0-9\\-]+).*SOURCE:\\s?([a-zA-Z]+).*', '')
const str = `SMS_TRIGGER: c12a460d-0476-40ab-a0ee-0f8a2a16f73b was fired for SOURCE: PT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}