using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"translate\(
(['""])
.+?
\1
\)";
string input = @"translate(""some text here"")
translate('some text here')
translate('""some text here...""')
translate('some \' text here')";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}