using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"translate\(
([\'""]) # capture quote char
((?:
(?!\1). # not a quote
| # or
\\\1 # escaped one
)* #
[^\\\\]?)\1 # match unescaped last quote char
\)";
string input = @"translate(""some text here"")
translate('some text here')
translate('""some text here...""')
translate(""a\""b\""c\""d"")
translate("")
translate(""a\""b""c\""d"")
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}