using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"translate\(
(['""])
(?:
.*?(?=\1\))
)
\1
\)";
string input = @"translate(""some text here"")
translate('some text here')
translate('""some text here...""')
translate(""a\""b\""c\""d"")
translate("") here comes the sun
translate(""a\""b""c\""d"") and here's the moon
translate('this is ugly wrong"")
translate(""as well as this')
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}