package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`translate\(
(['"])
(?:
.*?(?=\1\))
)
\1
\)`)
var str = `translate("some text here")
translate('some text here')
translate('"some text here..."')
translate("a\"b\"c\"d")
translate("") here comes the sun
translate("a\"b"c\"d") and here's the moon
translate('this is ugly wrong")
translate("as well as this')
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}