$re = '~(?<!https:|http:)//\s*((?:https?://|(?!//).)*)(?<!\s)\s*//~m';
$str = 'test //ita https://example.com lics// test // another // one
test //ita https://example.com lics this is a test https://example.com lics test / another // one
test ita https://example.com //lics// test // another // one';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);