import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "TMCA*";
final String string = "Request distribution failed\n\n"
+ "TMCA154891769\n"
+ "TMCA796121323\n\n"
+ "This error is a shit\n\n"
+ "I want this done\n\n"
+ "----------------\n\n"
+ "bla bla\n\n"
+ "Code: 141u231\n\n"
+ "--------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}