package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img[^>]+\>`)
var str = `<p><i>O Armário Amapá da Politorno, essencial e indispensável quando se trata de organização e bom gosto.</i></p>
<p>Disponível na cor:</p>
<p><img class="alignnone" style="display: block; margin-bottom: 30px;" src="https://www.solinemoveis.com.br/wp-content/uploads/2012/09/cores-de-madeira-branco.jpg" alt="cores-de-madeira-branco" width="153" height="189"></p>
<h4>Dimensões do Armário <strong> ARMP3-019 </strong>Amapá:</h4>
<p><img style="display: block; margin-bottom: 30px;" src="https://www.solinemoveis.com.br/wp-content/uploads/2012/09/armario-organizador-amapa-branco-politorno-dimensoes1.jpg" alt="armario-organizador-amapa-branco-politorno-dimensoes1"></p>
<p>Visite também nossa página no facebook: https://www.facebook.com/solinemoveis/</p>
<p><a href="http://www.soline.com.br"><br>
<img class="alignright size-medium" src="https://www.solinemoveis.com.br/wp-content/uploads/2014/09/visite-loja-online-button-soline-moveis-soline.png" alt="Armário Amapá" width="179" height="74"><br>
</a></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}