# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img[^>]+\>"
test_str = ("<p><i>O Armário Amapá da Politorno, essencial e indispensável quando se trata de organização e bom gosto.</i></p>\n"
"<p>Disponível na cor:</p>\n"
"<p><img class=\"alignnone\" style=\"display: block; margin-bottom: 30px;\" src=\"https://www.solinemoveis.com.br/wp-content/uploads/2012/09/cores-de-madeira-branco.jpg\" alt=\"cores-de-madeira-branco\" width=\"153\" height=\"189\"></p>\n"
"<h4>Dimensões do Armário <strong> ARMP3-019 </strong>Amapá:</h4>\n"
"<p><img style=\"display: block; margin-bottom: 30px;\" src=\"https://www.solinemoveis.com.br/wp-content/uploads/2012/09/armario-organizador-amapa-branco-politorno-dimensoes1.jpg\" alt=\"armario-organizador-amapa-branco-politorno-dimensoes1\"></p>\n"
"<p>Visite também nossa página no facebook: https://www.facebook.com/solinemoveis/</p>\n"
"<p><a href=\"http://www.soline.com.br\"><br>\n"
"<img class=\"alignright size-medium\" src=\"https://www.solinemoveis.com.br/wp-content/uploads/2014/09/visite-loja-online-button-soline-moveis-soline.png\" alt=\"Armário Amapá\" width=\"179\" height=\"74\"><br>\n"
"</a></p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.