using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_([_\d]*)[.]";
string input = @"myimage_1.jpg
myimage_1_1.jpg
myimage_1_1_1.jpg
myimage_1_1_1_1.jpg
myimage_1_1_1_1_1.jpg
anynumber_1_2_3_4_5_6.jpg
numbers_only_not_text_1.jpg
numbers_only_not_text_1_1.jpg
The '\d' could purely be replaced with '1' if that is all that is required to be removed.
Ensure to replace matached string with a further '.'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}