#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)((?:ht|f)tps?:\/\/(\w+\.\w{2}[\/\w-.]*))"
Local $sString = "http://matthiasweiss.at/asd/asd" & @CRLF & _
"" & @CRLF & _
"ftp://hallo.welt" & @CRLF & _
"" & @CRLF & _
"https://hallowelt.jpg" & @CRLF & _
"" & @CRLF & _
"http://asdasd.aa/jojoji.jiji" & @CRLF & _
"" & @CRLF & _
"mail@matthiasweiss.at" & @CRLF & _
"" & @CRLF & _
"http://matthiasweiss.at" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<a href="$1">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)