using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:ht|f)tps?:\/\/(\w+\.\w{2}[\/\w-.]*))";
string substitution = @"<a href=""$1"">$1</a>";
string input = @"http://matthiasweiss.at/asd/asd
ftp://hallo.welt
https://hallowelt.jpg
http://asdasd.aa/jojoji.jiji
mail@matthiasweiss.at
http://matthiasweiss.at
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}