use strict;
my $str = 'http://matthiasweiss.at/asd/asd
ftp://hallo.welt
https://hallowelt.jpg
http://asdasd.aa/jojoji.jiji
mail@matthiasweiss.at
http://matthiasweiss.at
';
my $regex = qr/((?:ht|f)tps?:\/\/(\w+\.\w{2}[\/\w-.]*))/ip;
my $subst = '<a href="$1">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";