re = /((?:ht|f)tps?:\/\/(\w+\.\w{2}[\/\w-.]*))/i
str = 'http://matthiasweiss.at/asd/asd
ftp://hallo.welt
https://hallowelt.jpg
http://asdasd.aa/jojoji.jiji
mail@matthiasweiss.at
http://matthiasweiss.at
'
subst = '<a href="$1">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result