// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((?:ht|f)tps?:\/\/(\w+\.\w{2}[\/\w-.]*))").unwrap();
let string = "http://matthiasweiss.at/asd/asd
ftp://hallo.welt
https://hallowelt.jpg
http://asdasd.aa/jojoji.jiji
mail@matthiasweiss.at
http://matthiasweiss.at
";
let substitution = "<a href=\"$1\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}