using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^02[0-9]{2}[-][0-9]{7}$";
string substitution = @"^[04](1|2)(2|4|6)$";
string input = @"0212-1234567";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}