// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^02[0-9]{2}[-][0-9]{7}$").unwrap();
let string = "0212-1234567";
let substitution = "^[04](1|2)(2|4|6)$";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}