import Foundation
let pattern = #"^02[0-9]{2}[-][0-9]{7}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0212-1234567"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"^[04](1|2)(2|4|6)$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)