# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{\{ *(ab|cd|ef|gh) *\}\} *\{\{ *(ab|cd|ef|gh) *\}\} *(\{\{ *(ab|cd|ef|gh) *\}\})* *(\{\{ *(ab|cd|ef|gh) *\}\})* *(\{\{ *(ab|cd|ef|gh) *\}\})* *(\{\{ *(ab|cd|ef|gh) *\}\})*/{{mul|$1|$2|$4|$6|$8|$10}} /gm;t' <<< "{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}
{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}
machintruc {{ab}} {{cd}}
{{ab}} {{cd}} {{ef}} [https://truc.org truc]
{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{lien web|url=tr.uc}}
{{mr}} Trucmuche
"