import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\(+[^()]*\\b(address|house).*";
final String string = "This is a string ((X.address)) test\n"
+ "This is a string ((X address)) test\n"
+ "This is a string (X address) test\n"
+ "This is a string (X.address) test\n"
+ "This is a string ((X and Y and Z address)) test\n\n"
+ "This is a string ((X.house)) test\n"
+ "This is a string ((X house)) test\n"
+ "This is a string (X house) test\n"
+ "This is a string (X.house) test\n"
+ "This is a string ((X and Y and Z house)) test";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}