#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{2,50}$)[A-ZÆØÅa-zæøå]+(?: [A-ZÆØÅa-zæøå]+)*(?:-[A-ZÆØÅa-zæøå]+(?: [A-ZÆØÅa-zæøå]+)*)?$"
Local $sString = "Janet Smith-Johnson" & @CRLF & _
"Mary-Ann Johnson" & @CRLF & _
"Sara Mary John-Smith" & @CRLF & _
"Sara Johnson" & @CRLF & _
"Sara Mary Johnson" & @CRLF & _
"" & @CRLF & _
"-Janet Mary" & @CRLF & _
"Mary-" & @CRLF & _
"" & @CRLF & _
" - "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")