package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d*)(\d{1})`)
var str = `2346`
var substitution = "$1.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}