#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(-\w+\s*.*)\n*$"
Local $sString = "-Give on result" & @CRLF & _
"-Second new text" & @CRLF & _
"-The third text" & @CRLF & _
"" & @CRLF & _
"Another paragraph without list." & @CRLF & _
"" & @CRLF & _
"-New list here"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")