#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:name#(\w+?)\^)?(?:value#(\w+?)\^)?(?:quantity#(\d+?))?"
Local $sString = "Name#Size^Value#S^Name#Color^Value#Black^Quantity#2" & @CRLF & _
"Name#Size^Value#XXL^Quantity#3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")