$re = '/(?:name#(\w+?)\^)?(?:value#(\w+?)\^)?(?:quantity#(\d+?))?/i';
$str = 'Name#Size^Value#S^Name#Color^Value#Black^Quantity#2
Name#Size^Value#XXL^Quantity#3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);