use strict;
my $str = '7510032485';
my $regex = qr/([\d]{2})([\d]{4})/p;
my $subst = '$1 $2 ';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";