re = /^(?:https?:\/\/)?(?:[^\.]+\.)?example\.com(\/.*)?$/m
str = 'https://example.com
http://www.example.com
http://example.com
https://example.com
www.example.com
example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end