#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\@(?P<key>[a-zA-Z0-9]+)\s{1,}(?P<value>.*)"
Local $sString = "/**" & @CRLF & _
"@author Marian Gabriel" & @CRLF & _
"@route /page/contact" & @CRLF & _
"@name Contact Plugin" & @CRLF & _
"@version 0.1beta" & @CRLF & _
"@company VMG" & @CRLF & _
"@type Page" & @CRLF & _
"**/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")