import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\@(?P<key>[a-zA-Z0-9]+)\\s{1,}(?P<value>.*)";
final String string = "/**\n"
+ "@author Marian Gabriel\n"
+ "@route /page/contact\n"
+ "@name Contact Plugin\n"
+ "@version 0.1beta\n"
+ "@company VMG\n"
+ "@type Page\n"
+ "**/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}