re = /\d{3}([-\s\.])?\d{3}\1?\d{4}/
str = '111-222.3333
111.222-3333
111-222 3333
111 222-3333
111-222-3333
111.222.3333
111 222 3333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end