// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)section:(.*?)subsection:([0-9]+)\s+((?:xy:[0-9]*_[^\n]+\r?\n)+)").unwrap();
let string = "<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>
<who know's whats here>
section:NumberOfSurvivorsPerVault
subsection:1958
xy:1_1034
xy:2_2334
...
<some other line>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}