package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^user\/[0-9A-F]{8}-[0-9A-F]{4}-[4][0-9A-F]{3}-[89AB][0-9A-F]{3}-[0-9A-F]{12}(?:\/.*)?$`)
var str = `user/a24a6ea4-ce75-4665-a070-57453082c256
user/a24a6ea4-ce75-4665-a070-57453082c256/photo
user/a24a6ea4-ce75-4665-a070-57453082c256asdasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}