package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-zÀ-ú]+ ?\-?[A-Za-zÀ-ú]+`)
var str = `téstê téstê téstê téstê-téstê`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}