$re = '/[A-Za-zÀ-ú]+ ?\-?[A-Za-zÀ-ú]+/';
$str = 'téstê téstê téstê téstê-téstê';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);