#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?'comando'\w+)(?'valor'\(.*?\))"
Local $sString = "" & @CRLF & _
"search(objeto(atributo.subatributo)).equals(1).and(search(objeto2(atributo2)).gte(1))" & @CRLF & _
"" & @CRLF & _
"group(objeto(atributo)).equals(1).orderby(atributo.field)" & @CRLF & _
"objeto(atributo).equals(1)" & @CRLF & _
"" & @CRLF & _
"search(objeto(attr)).and(seach(objeto(attr2)).and(search(objeto(attr3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")