# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?'comando'\w+)(?'valor'\(.*?\))"
test_str = ("\n"
"search(objeto(atributo.subatributo)).equals(1).and(search(objeto2(atributo2)).gte(1))\n\n"
"group(objeto(atributo)).equals(1).orderby(atributo.field)\n"
"objeto(atributo).equals(1)\n\n"
"search(objeto(attr)).and(seach(objeto(attr2)).and(search(objeto(attr3)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.