import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^PATIENT:.*-\\s+([^.]*?)\\s*\\.";
final String string = "PATIENT: 2029985 - COLLINS, JUNIOR .\n"
+ "PATIENT: 1235231-02 - JERRY JR, PATRICK .\n"
+ "PATIENT: 986435--EXP-- - JULIUS, DANIEL .\n"
+ "PATIENT: 2021118-02 - DRED-HARRY, KEVIN .";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}