$re = '/([0-9]+,[0-9]+|[0-9]+) (GB|MB) \(([0-9]+,[0-9]+|[0-9]+) [a-zA-Z]+[\/|`]s ?\)/';
$str = '5 GB (42,2 Mbit`s )
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);