const regex = /(?:\bfunction\s+(\w+)\([^()]*\)\s*\{|(?!^\G))(?:(?!\bfunction\s+\w+\([^()]*\)\s+{|}\h*\r?\n).)*?\$body\s*->\s*(\w+)|function\s*(.+?)\(/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bfunction\\s+(\\w+)\\([^()]*\\)\\s*\\{|(?!^\\G))(?:(?!\\bfunction\\s+\\w+\\([^()]*\\)\\s+{|}\\h*\\r?\\n).)*?\\$body\\s*->\\s*(\\w+)|function\\s*(.+?)\\(', 'sg')
const str = `function deviceUpdate(\$body)
{
}
function postad(\$body)
{
\$adtitle = \$body -> adtitle;
\$addescription = \$body -> addescription;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}