re = /(?:\bfunction\s+(\w+)\([^()]*\)\s*\{|(?!^\G))(?:(?!\bfunction\s+\w+\([^()]*\)\s+{|}\h*\r?\n).)*?\$body\s*->\s*(\w+)|function\s*(.+?)\(/
str = 'function deviceUpdate($body)
{
}
function postad($body)
{
$adtitle = $body -> adtitle;
$addescription = $body -> addescription;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end