using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Ea-e0-9]{8})";
string input = @",,aaaaaaaa,dddddddd,,e22221111,,22221111,,,22222222,,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}