#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:([1-9]?[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(?1)$"
Local $sString = "0.0.0.0" & @CRLF & _
"0.0.0.1" & @CRLF & _
"0.0.0.9" & @CRLF & _
"0.0.0.19" & @CRLF & _
"0.0.0.29" & @CRLF & _
"0.0.0.39" & @CRLF & _
"0.0.0.49" & @CRLF & _
"0.0.0.59" & @CRLF & _
"0.0.0.69" & @CRLF & _
"0.0.0.79" & @CRLF & _
"0.0.0.89" & @CRLF & _
"0.0.0.99" & @CRLF & _
"0.0.0.100" & @CRLF & _
"0.0.0.109" & @CRLF & _
"0.0.0.199" & @CRLF & _
"0.0.0.200" & @CRLF & _
"0.0.0.209" & @CRLF & _
"0.0.0.210" & @CRLF & _
"0.0.0.219" & @CRLF & _
"0.0.0.229" & @CRLF & _
"0.0.0.239" & @CRLF & _
"0.0.0.249" & @CRLF & _
"0.0.0.250" & @CRLF & _
"0.0.0.251" & @CRLF & _
"0.0.0.253" & @CRLF & _
"0.0.0.254" & @CRLF & _
"0.0.0.255" & @CRLF & _
"0.0.0.256" & @CRLF & _
"127.0.0.1" & @CRLF & _
"255.255.255.0" & @CRLF & _
"192.168.0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")