# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:([1-9]?[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(?1)$"
test_str = ("0.0.0.0\n"
"0.0.0.1\n"
"0.0.0.9\n"
"0.0.0.19\n"
"0.0.0.29\n"
"0.0.0.39\n"
"0.0.0.49\n"
"0.0.0.59\n"
"0.0.0.69\n"
"0.0.0.79\n"
"0.0.0.89\n"
"0.0.0.99\n"
"0.0.0.100\n"
"0.0.0.109\n"
"0.0.0.199\n"
"0.0.0.200\n"
"0.0.0.209\n"
"0.0.0.210\n"
"0.0.0.219\n"
"0.0.0.229\n"
"0.0.0.239\n"
"0.0.0.249\n"
"0.0.0.250\n"
"0.0.0.251\n"
"0.0.0.253\n"
"0.0.0.254\n"
"0.0.0.255\n"
"0.0.0.256\n"
"127.0.0.1\n"
"255.255.255.0\n"
"192.168.0.1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.